summaryrefslogtreecommitdiffstats
path: root/hl/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
commitff47a7df1bc78ddf36d247c76abc03e6861b1c01 (patch)
tree78b4786655f00c75616fc894deec00989bb1f724 /hl/c++/test/CMakeLists.txt
parentec5f5c868fb4dad3452db045c627fe258b152cd2 (diff)
downloadhdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.zip
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.gz
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.bz2
[svn-r19362] Move Windows specific compile and link flags to macros
Diffstat (limited to 'hl/c++/test/CMakeLists.txt')
-rw-r--r--hl/c++/test/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/hl/c++/test/CMakeLists.txt b/hl/c++/test/CMakeLists.txt
index afcb8fe..cf621a2 100644
--- a/hl/c++/test/CMakeLists.txt
+++ b/hl/c++/test/CMakeLists.txt
@@ -18,16 +18,7 @@ IF (BUILD_TESTING)
ADD_EXECUTABLE (hl_ptableTest ${HDF5_HL_CPP_TEST_SOURCE_DIR}/ptableTest.cpp)
H5_NAMING (hl_ptableTest)
- IF (WIN32)
- IF (MSVC)
- IF (NOT BUILD_SHARED_LIBS)
- SET_TARGET_PROPERTIES (hl_ptableTest
- PROPERTIES
- LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
- )
- ENDIF (NOT BUILD_SHARED_LIBS)
- ENDIF (MSVC)
- ENDIF (WIN32)
+ TARGET_WIN_PROPERTIES (hl_ptableTest)
TARGET_LINK_LIBRARIES (
hl_ptableTest
${HDF5_LIB_TARGET}