summaryrefslogtreecommitdiffstats
path: root/hl/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
commit2f13382883e54af2d0584bb8b763ce6049d15826 (patch)
treea30ee54236fa8ab56bfc49b6f7b4523d6df191c1 /hl/c++/test/CMakeLists.txt
parenteb5eba9aee6cb002b2a5278e00e232f4a2118bf6 (diff)
downloadhdf5-2f13382883e54af2d0584bb8b763ce6049d15826.zip
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.gz
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.bz2
[svn-r19037] Added executable Linker Flag for MSVC static builds: /NODEFAULTLIB:MSVCRT
Added VERSION vars for inclusion into auto snapshot version update script Tested windows
Diffstat (limited to 'hl/c++/test/CMakeLists.txt')
-rw-r--r--hl/c++/test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/hl/c++/test/CMakeLists.txt b/hl/c++/test/CMakeLists.txt
index c0a94f8..e9b09da 100644
--- a/hl/c++/test/CMakeLists.txt
+++ b/hl/c++/test/CMakeLists.txt
@@ -18,6 +18,16 @@ IF (BUILD_TESTING)
ADD_EXECUTABLE (hl_ptableTest ${HDF5_HL_CPP_TEST_SOURCE_DIR}/ptableTest.cpp)
H5_NAMING (hl_ptableTest)
+ IF (WIN32)
+ IF (MSVC)
+ IF (NOT BUILD_SHARED_LIBS)
+ SET_TARGET_PROPERTIES (hl_ptableTest
+ PROPERTIES
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ )
+ ENDIF (NOT BUILD_SHARED_LIBS)
+ ENDIF (MSVC)
+ ENDIF (WIN32)
TARGET_LINK_LIBRARIES (
hl_ptableTest
${HDF5_LIB_TARGET}