summaryrefslogtreecommitdiffstats
path: root/hl/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2018-05-22 16:48:44 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2018-05-22 16:48:44 (GMT)
commit4ddd7704b6f07bf5f23cbb006b879f28ebd84492 (patch)
treef40e6f0f6108d9b10fdf30ace82cf2e0ff9654b6 /hl/examples/CMakeLists.txt
parent32f57355c28efb390a25865eb3adf9f0b66c6e56 (diff)
parenteb8d35dd8cfd7339c203f758cf9637ac1cdc7a96 (diff)
downloadhdf5-4ddd7704b6f07bf5f23cbb006b879f28ebd84492.zip
hdf5-4ddd7704b6f07bf5f23cbb006b879f28ebd84492.tar.gz
hdf5-4ddd7704b6f07bf5f23cbb006b879f28ebd84492.tar.bz2
Merge branch 'develop' into hdf5_1_10.sync
Diffstat (limited to 'hl/examples/CMakeLists.txt')
-rw-r--r--hl/examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/hl/examples/CMakeLists.txt b/hl/examples/CMakeLists.txt
index 2f9019d..97c6de5 100644
--- a/hl/examples/CMakeLists.txt
+++ b/hl/examples/CMakeLists.txt
@@ -28,7 +28,7 @@ set (examples
foreach (example ${examples})
add_executable (hl_ex_${example} ${HDF5_HL_EXAMPLES_SOURCE_DIR}/${example}.c)
- target_include_directories(hl_ex_${example} PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR}")
+ target_include_directories(hl_ex_${example} PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
TARGET_C_PROPERTIES (hl_ex_${example} STATIC)
target_link_libraries (hl_ex_${example} PRIVATE ${HDF5_HL_LIB_TARGET} ${HDF5_LIB_TARGET})
set_target_properties (hl_ex_${example} PROPERTIES FOLDER examples/hl)