summaryrefslogtreecommitdiffstats
path: root/hl/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:31:46 (GMT)
commitff47a7df1bc78ddf36d247c76abc03e6861b1c01 (patch)
tree78b4786655f00c75616fc894deec00989bb1f724 /hl/examples/CMakeLists.txt
parentec5f5c868fb4dad3452db045c627fe258b152cd2 (diff)
downloadhdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.zip
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.gz
hdf5-ff47a7df1bc78ddf36d247c76abc03e6861b1c01.tar.bz2
[svn-r19362] Move Windows specific compile and link flags to macros
Diffstat (limited to 'hl/examples/CMakeLists.txt')
-rw-r--r--hl/examples/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/hl/examples/CMakeLists.txt b/hl/examples/CMakeLists.txt
index 0d29b7f..227f066 100644
--- a/hl/examples/CMakeLists.txt
+++ b/hl/examples/CMakeLists.txt
@@ -30,16 +30,7 @@ SET (examples
FOREACH (example ${examples})
ADD_EXECUTABLE (hl_ex_${example} ${HDF5_HL_EXAMPLES_SOURCE_DIR}/${example}.c)
H5_NAMING (hl_ex_${example})
- IF (WIN32)
- IF (MSVC)
- IF (NOT BUILD_SHARED_LIBS)
- SET_TARGET_PROPERTIES (hl_ex_${example}
- PROPERTIES
- LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
- )
- ENDIF (NOT BUILD_SHARED_LIBS)
- ENDIF (MSVC)
- ENDIF (WIN32)
+ TARGET_WIN_PROPERTIES (hl_ex_${example})
TARGET_LINK_LIBRARIES (hl_ex_${example} ${HDF5_HL_LIB_TARGET} ${HDF5_LIB_TARGET})
ENDFOREACH (example ${examples})