summaryrefslogtreecommitdiffstats
path: root/hl/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-03-26 15:00:35 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-03-26 15:00:35 (GMT)
commitd9020f2e35342605b26b6260e05cc4a2cef2327b (patch)
tree344bb1fde0fd8def1e2228abadc7e64b605e11dc /hl/examples/CMakeLists.txt
parent3944dcb308de2d380822d2d56cf0d3bd96db5c8f (diff)
downloadhdf5-d9020f2e35342605b26b6260e05cc4a2cef2327b.zip
hdf5-d9020f2e35342605b26b6260e05cc4a2cef2327b.tar.gz
hdf5-d9020f2e35342605b26b6260e05cc4a2cef2327b.tar.bz2
[svn-r24906] Merge latest CMake changes from trunk.
Tested: local linux
Diffstat (limited to 'hl/examples/CMakeLists.txt')
-rw-r--r--hl/examples/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/hl/examples/CMakeLists.txt b/hl/examples/CMakeLists.txt
index a9c5258..7847dbe 100644
--- a/hl/examples/CMakeLists.txt
+++ b/hl/examples/CMakeLists.txt
@@ -1,10 +1,10 @@
-cmake_minimum_required (VERSION 2.8.10)
+cmake_minimum_required (VERSION 2.8.11)
PROJECT (HDF5_HL_EXAMPLES )
#-----------------------------------------------------------------------------
# Define Sources
#-----------------------------------------------------------------------------
-SET (examples
+set (examples
ex_lite1
ex_lite2 #ex_lite2 PROPERTIES DEPENDS ex_lite1)
ex_lite3
@@ -26,16 +26,16 @@ SET (examples
ex_ds1
)
-FOREACH (example ${examples})
- ADD_EXECUTABLE (hl_ex_${example} ${HDF5_HL_EXAMPLES_SOURCE_DIR}/${example}.c)
+foreach (example ${examples})
+ add_executable (hl_ex_${example} ${HDF5_HL_EXAMPLES_SOURCE_DIR}/${example}.c)
TARGET_NAMING (hl_ex_${example} ${LIB_TYPE})
TARGET_C_PROPERTIES (hl_ex_${example} " " " ")
- TARGET_LINK_LIBRARIES (hl_ex_${example} ${HDF5_HL_LIB_TARGET} ${HDF5_LIB_TARGET})
- SET_TARGET_PROPERTIES (hl_ex_${example} PROPERTIES FOLDER examples/hl)
-ENDFOREACH (example ${examples})
+ target_link_libraries (hl_ex_${example} ${HDF5_HL_LIB_TARGET} ${HDF5_LIB_TARGET})
+ set_target_properties (hl_ex_${example} PROPERTIES FOLDER examples/hl)
+endforeach (example ${examples})
-IF (BUILD_TESTING)
+if (BUILD_TESTING)
- INCLUDE (CMakeTests.cmake)
+ include (CMakeTests.cmake)
-ENDIF (BUILD_TESTING)
+endif (BUILD_TESTING)