summaryrefslogtreecommitdiffstats
path: root/hl/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
commit2f13382883e54af2d0584bb8b763ce6049d15826 (patch)
treea30ee54236fa8ab56bfc49b6f7b4523d6df191c1 /hl/examples/CMakeLists.txt
parenteb5eba9aee6cb002b2a5278e00e232f4a2118bf6 (diff)
downloadhdf5-2f13382883e54af2d0584bb8b763ce6049d15826.zip
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.gz
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.bz2
[svn-r19037] Added executable Linker Flag for MSVC static builds: /NODEFAULTLIB:MSVCRT
Added VERSION vars for inclusion into auto snapshot version update script Tested windows
Diffstat (limited to 'hl/examples/CMakeLists.txt')
-rw-r--r--hl/examples/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/hl/examples/CMakeLists.txt b/hl/examples/CMakeLists.txt
index 934856a..0d29b7f 100644
--- a/hl/examples/CMakeLists.txt
+++ b/hl/examples/CMakeLists.txt
@@ -30,6 +30,16 @@ SET (examples
FOREACH (example ${examples})
ADD_EXECUTABLE (hl_ex_${example} ${HDF5_HL_EXAMPLES_SOURCE_DIR}/${example}.c)
H5_NAMING (hl_ex_${example})
+ IF (WIN32)
+ IF (MSVC)
+ IF (NOT BUILD_SHARED_LIBS)
+ SET_TARGET_PROPERTIES (hl_ex_${example}
+ PROPERTIES
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ )
+ ENDIF (NOT BUILD_SHARED_LIBS)
+ ENDIF (MSVC)
+ ENDIF (WIN32)
TARGET_LINK_LIBRARIES (hl_ex_${example} ${HDF5_HL_LIB_TARGET} ${HDF5_LIB_TARGET})
ENDFOREACH (example ${examples})