summaryrefslogtreecommitdiffstats
path: root/hl/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-01 15:04:59 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-01 15:04:59 (GMT)
commit3f2f490a0f5da29ee9e4d4d74449a3e0b2713ce1 (patch)
treefe1d2a1f534515f9054b0f7a027748ee120864a6 /hl/examples/Makefile.am
parent516c242b04b60a3f51d004977bee09ff6f8968b7 (diff)
downloadhdf5-3f2f490a0f5da29ee9e4d4d74449a3e0b2713ce1.zip
hdf5-3f2f490a0f5da29ee9e4d4d74449a3e0b2713ce1.tar.gz
hdf5-3f2f490a0f5da29ee9e4d4d74449a3e0b2713ce1.tar.bz2
[svn-r11993] Purpose:
Added HL examples Description: Examples existed for the HL lite, image, and table interfaces, but were never included in the distro... until now! Solution: Added source files to CVS, updated Makefile and MANIFEST. Platforms tested: mir, heping, shanti
Diffstat (limited to 'hl/examples/Makefile.am')
-rw-r--r--hl/examples/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/hl/examples/Makefile.am b/hl/examples/Makefile.am
index 6a436af..eb55293 100644
--- a/hl/examples/Makefile.am
+++ b/hl/examples/Makefile.am
@@ -24,11 +24,14 @@ if BUILD_PARALLEL_CONDITIONAL
TEST_PROG_PARA =
endif
+# Example directory
+EXAMPLEDIR=$(docdir)/hdf5/examples/hl/c
+
# Example programs.
# Don't tell automake about them, because if it knew they were programs,
# it would try to compile them instead of using the h5cc script.
# Use the boilerplate in config/examples.am instead.
-TEST_PROG = ptExampleFL ptExampleVL
+TEST_PROG = ex_lite1 ex_lite2 ex_lite3 ptExampleFL ptExampleVL
# Install files
# List all file that should be installed in examples directory
@@ -42,8 +45,8 @@ else
$(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif
-# Example directory
-EXAMPLEDIR=$(docdir)/hdf5/examples/hl/c
+# ex_lite2 uses a file created by ex_lite1
+ex_lite2.chkexe_: ex_lite1.chkexe_
# List dependencies for each program. Normally, automake would take
# care of this for us, but if we tell automake about the programs it
@@ -51,6 +54,9 @@ EXAMPLEDIR=$(docdir)/hdf5/examples/hl/c
# an inelegant way of solving the problem.
# All programs share the same build rule and a dependency on the main hdf5
# library above.
+ex_lite1: $(srcdir)/ex_lite1.c
+ex_lite2: $(srcdir)/ex_lite2.c
+ex_lite3: $(srcdir)/ex_lite3.c
ptExampleFL: $(srcdir)/ptExampleFL.c
ptExampleVL: $(srcdir)/ptExampleVL.c