summaryrefslogtreecommitdiffstats
path: root/hl/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2007-01-26 15:00:09 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2007-01-26 15:00:09 (GMT)
commit3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544 (patch)
tree49c0de341039f917e0bb82799a778ab3ad7ad4dc /hl/examples/Makefile.am
parentfd63747fd649c609abcbcd6c6143cbe564092867 (diff)
downloadhdf5-3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544.zip
hdf5-3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544.tar.gz
hdf5-3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544.tar.bz2
[svn-r13203] Unable to replicate Daily Test error, but hopefully this is a fix anyway.
The examples had been depending on the build libraries in src, but should have been depending only on the installed h5cc. Fixed this. Tested on kagiso (dependency change only, and was unable to replicate the problem on any system). Real test will be Daily Tests tonight.
Diffstat (limited to 'hl/examples/Makefile.am')
-rw-r--r--hl/examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/hl/examples/Makefile.am b/hl/examples/Makefile.am
index a98e4a5..df3a8ad 100644
--- a/hl/examples/Makefile.am
+++ b/hl/examples/Makefile.am
@@ -43,10 +43,11 @@ TEST_PROG = ex_lite1 ex_lite2 ex_lite3 ptExampleFL ptExampleVL \
INSTALL_FILES = ptExampleFL.c ptExampleVL.c
# Additional dependencies for each program are listed below.
-$(EXTRA_PROG): $(LIBHDF5) $(LIBH5_HL)
if BUILD_PARALLEL_CONDITIONAL
+$(EXTRA_PROG): $(H5CC_PP)
$(H5CC_PP) $(CFLAGS) -o $@ $(srcdir)/$@.c;
else
+$(EXTRA_PROG): $(H5CC)
$(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif