summaryrefslogtreecommitdiffstats
path: root/hl/examples/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-09 04:55:49 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-09 04:55:49 (GMT)
commitf32690b53c0872faf9e9ee0d0492cce360f72938 (patch)
treea34e9d414dc486bd58509dd8671d44d9d22a6879 /hl/examples/Makefile.am
parenta2c8dc8972a5b757ec94fa60a91559bc599db8ec (diff)
downloadhdf5-f32690b53c0872faf9e9ee0d0492cce360f72938.zip
hdf5-f32690b53c0872faf9e9ee0d0492cce360f72938.tar.gz
hdf5-f32690b53c0872faf9e9ee0d0492cce360f72938.tar.bz2
[svn-r24997] Added compiler versions for mpich to settings file and configure summary.
For make installcheck, compile and run installed examples using the installed scripts. They were being compiled but not run. Add Fortran2003 examples to the run-ex-fortran script when fortran2003 is enabled. Set flag to -O3 in production mode for Intel compilers other than those with specified other settings. Gentoo patches: Remove unnecessary setting of LD_LIBRARY_PATH from configure. Prevent potential array subscript out of bounds error in perform/pio_engine.c and sio_engine.c. Tested with h5committest on jam, koala, ostrich and platypus, on emu and kite, and parallel tests on jam, koala and platypus with mpich built with gnu 4.8.2 and with intel compilers.
Diffstat (limited to 'hl/examples/Makefile.am')
-rw-r--r--hl/examples/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/hl/examples/Makefile.am b/hl/examples/Makefile.am
index 5108c5e..ba200ed 100644
--- a/hl/examples/Makefile.am
+++ b/hl/examples/Makefile.am
@@ -29,6 +29,8 @@ endif
# Note: no '/' after DESTDIR. Explanation in commence.am
EXAMPLEDIR=${DESTDIR}$(exec_prefix)/share/hdf5_examples/hl/c
EXAMPLETOPDIR=${DESTDIR}$(exec_prefix)/share/hdf5_examples/hl
+INSTALL_SCRIPT_FILES = run-hlc-ex.sh
+INSTALL_TOP_SCRIPT_FILES = run-hl-ex.sh
# Example programs.
# Don't tell automake about them, because if it knew they were programs,
@@ -40,6 +42,7 @@ EXAMPLE_PROG = ex_lite1 ex_lite2 ex_lite3 ptExampleFL \
ex_table_05 ex_table_06 ex_table_07 ex_table_08 \
ex_table_09 ex_table_10 ex_table_11 ex_table_12 \
ex_ds1
+TEST_EXAMPLES_SCRIPT=$(INSTALL_SCRIPT_FILES)
# Install files
# List all file that should be installed in examples directory
@@ -50,8 +53,6 @@ INSTALL_FILES = ex_lite1.c ex_lite2.c ex_lite3.c ptExampleFL.c \
ex_table_09.c ex_table_10.c ex_table_11.c ex_table_12.c \
ex_ds1.c image24pixel.txt image8.txt pal_rgb.h
-INSTALL_SCRIPT_FILES = run-hlc-ex.sh
-INSTALL_TOP_SCRIPT_FILES = run-hl-ex.sh
# Additional dependencies for each program are listed below.
if BUILD_PARALLEL_CONDITIONAL