summaryrefslogtreecommitdiffstats
path: root/hl/examples/Makefile.am
diff options
context:
space:
mode:
authorPedro Vicente Nunes <pvn@hdfgroup.org>2006-03-06 16:11:11 (GMT)
committerPedro Vicente Nunes <pvn@hdfgroup.org>2006-03-06 16:11:11 (GMT)
commita83d815631e9981f3a89f4347d6a481e0fb7c62d (patch)
treedb77b10d8c5c6247f59d0352a747bcc4a70babcd /hl/examples/Makefile.am
parent0f8fa98da0b4b61173cc82f3123c736c1eec1552 (diff)
downloadhdf5-a83d815631e9981f3a89f4347d6a481e0fb7c62d.zip
hdf5-a83d815631e9981f3a89f4347d6a481e0fb7c62d.tar.gz
hdf5-a83d815631e9981f3a89f4347d6a481e0fb7c62d.tar.bz2
[svn-r12009] Purpose:
add examples Description: add examples for HL (image, table and dimension scales) Solution: Platforms tested: linux Misc. update:
Diffstat (limited to 'hl/examples/Makefile.am')
-rw-r--r--hl/examples/Makefile.am35
1 files changed, 30 insertions, 5 deletions
diff --git a/hl/examples/Makefile.am b/hl/examples/Makefile.am
index eb55293..4690474 100644
--- a/hl/examples/Makefile.am
+++ b/hl/examples/Makefile.am
@@ -31,18 +31,30 @@ EXAMPLEDIR=$(docdir)/hdf5/examples/hl/c
# Don't tell automake about them, because if it knew they were programs,
# it would try to compile them instead of using the h5cc script.
# Use the boilerplate in config/examples.am instead.
-TEST_PROG = ex_lite1 ex_lite2 ex_lite3 ptExampleFL ptExampleVL
+TEST_PROG = ex_lite1 ex_lite2 ex_lite3 \
+ ex_image1 ex_image2 \
+ ex_table_01 ex_table_02 ex_table_03 ex_table_04 \
+ ex_table_05 ex_table_06 ex_table_07 ex_table_08 \
+ ex_table_09 ex_table_10 ex_table_11 ex_table_12 \
+ ex_ds1 \
+ ptExampleFL ptExampleVL
# Install files
# List all file that should be installed in examples directory
-INSTALL_FILES = ptExampleFL.c ptExampleVL.c
+INSTALL_FILES = ex_lite1.c ex_lite2.c ex_lite3.c \
+ ex_image1.c ex_image2.c \
+ ex_table_01.c ex_table_02.c ex_table_03.c ex_table_04.c \
+ ex_table_05.c ex_table_06.c ex_table_07.c ex_table_08.c \
+ ex_table_09.c ex_table_10.c ex_table_11.c ex_table_12.c \
+ ex_ds1.c \
+ ptExampleFL.c ptExampleVL.c
# Additional dependencies for each program are listed below.
$(EXTRA_PROG): $(LIBHDF5) $(LIBH5_HL)
if BUILD_PARALLEL_CONDITIONAL
- $(H5CC_PP) $(CFLAGS) -o $@ $(srcdir)/$@.c;
+ $(H5CC_PP) $(CFLAGS) -o $@ $(srcdir)/$@.c;
else
- $(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
+ $(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif
# ex_lite2 uses a file created by ex_lite1
@@ -57,8 +69,21 @@ ex_lite2.chkexe_: ex_lite1.chkexe_
ex_lite1: $(srcdir)/ex_lite1.c
ex_lite2: $(srcdir)/ex_lite2.c
ex_lite3: $(srcdir)/ex_lite3.c
+ex_image1: $(srcdir)/ex_image1.c
+ex_image2: $(srcdir)/ex_image2.c
+ex_table_01: $(srcdir)/ex_table_01.c
+ex_table_02: $(srcdir)/ex_table_02.c
+ex_table_03: $(srcdir)/ex_table_03.c
+ex_table_04: $(srcdir)/ex_table_04.c
+ex_table_05: $(srcdir)/ex_table_05.c
+ex_table_06: $(srcdir)/ex_table_06.c
+ex_table_07: $(srcdir)/ex_table_07.c
+ex_table_08: $(srcdir)/ex_table_08.c
+ex_table_09: $(srcdir)/ex_table_09.c
+ex_table_10: $(srcdir)/ex_table_10.c
+ex_table_11: $(srcdir)/ex_table_11.c
+ex_table_12: $(srcdir)/ex_table_12.c
ptExampleFL: $(srcdir)/ptExampleFL.c
ptExampleVL: $(srcdir)/ptExampleVL.c
-
include $(top_srcdir)/config/examples.am
include $(top_srcdir)/config/conclude.am