summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-03 15:44:57 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-03 15:44:57 (GMT)
commit01a77cbfb17d8802a9f135bb95a2b2ec57f75410 (patch)
tree5ddb626fd46c8f784b890f5a575f0ab5eccfe2c6 /hl/fortran/examples/CMakeLists.txt
parent1ab0814a4320eb8a4b93a85048419302218aeb34 (diff)
downloadhdf5-01a77cbfb17d8802a9f135bb95a2b2ec57f75410.zip
hdf5-01a77cbfb17d8802a9f135bb95a2b2ec57f75410.tar.gz
hdf5-01a77cbfb17d8802a9f135bb95a2b2ec57f75410.tar.bz2
LINK_FLAGS must be separate property sets
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index 05cfaa4..97ddce8 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -20,18 +20,18 @@ foreach (example ${examples})
PRIVATE
${HDF5_HL_F90_LIB_TARGET} ${HDF5_F90_LIB_TARGET} ${HDF5_LIB_TARGET}
)
+ set_property(TARGET hl_f90_ex_${example} APPEND_STRING PROPERTY
+ LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"-SUBSYSTEM:CONSOLE">
+ )
+ set_property(TARGET hl_f90_ex_${example} APPEND_STRING PROPERTY
+ LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_LINK_FLAGS}>
+ )
set_target_properties (hl_f90_ex_${example} PROPERTIES
LINKER_LANGUAGE Fortran
FOLDER examples/hl/fortran
- LINK_FLAGS
- "$<$<STREQUAL:\"x${CMAKE_Fortran_SIMULATE_ID}\",\"xMSVC\">:\"-SUBSYSTEM:CONSOLE\">
- $<$<STREQUAL:\"x${CMAKE_Fortran_SIMULATE_ID}\",\"xMSVC\">:${WIN_LINK_FLAGS}>"
)
-
endforeach ()
if (BUILD_TESTING)
-
include (CMakeTests.cmake)
-
endif ()