summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
commit2f13382883e54af2d0584bb8b763ce6049d15826 (patch)
treea30ee54236fa8ab56bfc49b6f7b4523d6df191c1 /hl/fortran/examples/CMakeLists.txt
parenteb5eba9aee6cb002b2a5278e00e232f4a2118bf6 (diff)
downloadhdf5-2f13382883e54af2d0584bb8b763ce6049d15826.zip
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.gz
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.bz2
[svn-r19037] Added executable Linker Flag for MSVC static builds: /NODEFAULTLIB:MSVCRT
Added VERSION vars for inclusion into auto snapshot version update script Tested windows
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index 64fd9df..bd9a695 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -19,17 +19,22 @@ SET (examples
FOREACH (example ${examples})
ADD_EXECUTABLE (hl_f90_ex_${example} ${HDF5_HL_EXAMPLES_SOURCE_DIR}/${example}.f90)
H5_NAMING (hl_f90_ex_${example})
- IF (BUILD_SHARED_LIBS)
- IF (WIN32)
- IF (MSVC)
+ IF (WIN32)
+ IF (MSVC)
+ IF (BUILD_SHARED_LIBS)
SET_TARGET_PROPERTIES (hl_f90_ex_${example}
PROPERTIES
COMPILE_FLAGS "/dll"
LINK_FLAGS "/SUBSYSTEM:CONSOLE"
)
- ENDIF (MSVC)
- ENDIF (WIN32)
- ENDIF (BUILD_SHARED_LIBS)
+ ELSE (BUILD_SHARED_LIBS)
+ SET_TARGET_PROPERTIES (hl_f90_ex_${example}
+ PROPERTIES
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ )
+ ENDIF (BUILD_SHARED_LIBS)
+ ENDIF (MSVC)
+ ENDIF (WIN32)
TARGET_LINK_LIBRARIES (hl_f90_ex_${example}
${HDF5_HL_F90_LIB_TARGET}
${HDF5_F90_LIB_TARGET}