summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-12-03 22:26:37 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-12-03 22:26:37 (GMT)
commit449373deb3dba60b52964cbd86ebe0021d019cfb (patch)
treea842dfed3fc72db374feeab57d3e3040ecb833cf /hl/fortran/examples/CMakeLists.txt
parent109294e6e20afd46e3a1bdc722d900cec839716d (diff)
downloadhdf5-449373deb3dba60b52964cbd86ebe0021d019cfb.zip
hdf5-449373deb3dba60b52964cbd86ebe0021d019cfb.tar.gz
hdf5-449373deb3dba60b52964cbd86ebe0021d019cfb.tar.bz2
[svn-r19870] Add tests for examples.
Tested: local linux
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index 5e20da3..7f1dec5 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -26,4 +26,9 @@ FOREACH (example ${examples})
${HDF5_LIB_TARGET}
)
SET_TARGET_PROPERTIES (hl_f90_ex_${example} PROPERTIES LINKER_LANGUAGE Fortran)
+
+ IF (BUILD_TESTING)
+ ADD_TEST (NAME hl_f90_ex_${example} COMMAND $<TARGET_FILE:hl_f90_ex_${example}>)
+ ENDIF (BUILD_TESTING)
+
ENDFOREACH (example ${examples})