summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-08-19 21:49:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-08-19 21:49:44 (GMT)
commitc502d81a8c87dd2bce47a5476e3331b04fc69322 (patch)
tree2549ab26136222cdfae89d4279707051cbb716b0 /hl/fortran/examples/CMakeLists.txt
parentfcb21bb3dde491209881dc99eb0adc9198f21452 (diff)
downloadhdf5-c502d81a8c87dd2bce47a5476e3331b04fc69322.zip
hdf5-c502d81a8c87dd2bce47a5476e3331b04fc69322.tar.gz
hdf5-c502d81a8c87dd2bce47a5476e3331b04fc69322.tar.bz2
[svn-r24029] Move TESTS to seperate file to allow easier editing by all developers.
Tested: local linux
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index df7fd24..0f663c7 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -27,8 +27,10 @@ FOREACH (example ${examples})
SET_TARGET_PROPERTIES (hl_f90_ex_${example} PROPERTIES LINKER_LANGUAGE Fortran)
SET_TARGET_PROPERTIES (hl_f90_ex_${example} PROPERTIES FOLDER examples/hl/fortran)
- IF (BUILD_TESTING)
- ADD_TEST (NAME hl_f90_ex_${example} COMMAND $<TARGET_FILE:hl_f90_ex_${example}>)
- ENDIF (BUILD_TESTING)
-
ENDFOREACH (example ${examples})
+
+IF (BUILD_TESTING)
+
+ INCLUDE (CMakeTests.cmake)
+
+ENDIF (BUILD_TESTING)