summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-04-17 20:57:51 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-04-17 20:57:58 (GMT)
commit46f2a2a432c4077d94c4a3f2126ee0694fd9f0af (patch)
tree9538508039dd7f4aaa488c8bf81f8d3ae2c28727 /hl/fortran/examples/CMakeLists.txt
parent61a2456995e17ca542bbbc67fb07f8d44a38da93 (diff)
downloadhdf5-46f2a2a432c4077d94c4a3f2126ee0694fd9f0af.zip
hdf5-46f2a2a432c4077d94c4a3f2126ee0694fd9f0af.tar.gz
hdf5-46f2a2a432c4077d94c4a3f2126ee0694fd9f0af.tar.bz2
TRILABS-19 Initial conversion of include_directories to targets
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index 411ceea..eae3de5 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -1,14 +1,6 @@
cmake_minimum_required (VERSION 3.10)
PROJECT (HDF5_HL_F90_EXAMPLES C CXX Fortran)
-#-----------------------------------------------------------------------------
-# Setup include Directories
-#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (
- ${HDF5_F90_BINARY_DIR}
- ${HDF5_F90_SRC_DIR}/src
-)
-
set (examples
exlite
ex_ds1
@@ -23,6 +15,7 @@ foreach (example ${examples})
${HDF5_LIB_TARGET}
)
target_include_directories (hl_f90_ex_${example} PRIVATE ${CMAKE_Fortran_MODULE_DIRECTORY}/static)
+ set_property(TARGET hl_f90_ex_${example} APPEND PROPERTY INCLUDE_DIRECTORIES "${HDF5_F90_BINARY_DIR};${HDF5_F90_SRC_DIR}/src")
set_target_properties (hl_f90_ex_${example} PROPERTIES LINKER_LANGUAGE Fortran)
set_target_properties (hl_f90_ex_${example} PROPERTIES FOLDER examples/hl/fortran)