summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-03 16:57:30 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-03 16:57:30 (GMT)
commit1d1333ed6b51ef94862c50fe35fa52bea7756139 (patch)
tree5f02c4417e0846210a5e8f6d1a8280436edfe75c /hl/fortran/examples/CMakeLists.txt
parent01a77cbfb17d8802a9f135bb95a2b2ec57f75410 (diff)
downloadhdf5-1d1333ed6b51ef94862c50fe35fa52bea7756139.zip
hdf5-1d1333ed6b51ef94862c50fe35fa52bea7756139.tar.gz
hdf5-1d1333ed6b51ef94862c50fe35fa52bea7756139.tar.bz2
Revert to old style for LINK_FLAGS gen expr not working
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index 97ddce8..bd33a19 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -20,12 +20,15 @@ foreach (example ${examples})
PRIVATE
${HDF5_HL_F90_LIB_TARGET} ${HDF5_F90_LIB_TARGET} ${HDF5_LIB_TARGET}
)
- set_property(TARGET hl_f90_ex_${example} APPEND_STRING PROPERTY
- LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"-SUBSYSTEM:CONSOLE">
- )
- set_property(TARGET hl_f90_ex_${example} APPEND_STRING PROPERTY
- LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_LINK_FLAGS}>
- )
+# set_property(TARGET hl_f90_ex_${example} APPEND PROPERTY
+# LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"-SUBSYSTEM:CONSOLE">
+# )
+# set_property(TARGET hl_f90_ex_${example} APPEND PROPERTY
+# LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_LINK_FLAGS}>
+# )
+ if(MSVC)
+ set_property(TARGET hl_f90_ex_${example} APPEND PROPERTY LINK_FLAGS "-SUBSYSTEM:CONSOLE;${WIN_LINK_FLAGS}")
+ endif()
set_target_properties (hl_f90_ex_${example} PROPERTIES
LINKER_LANGUAGE Fortran
FOLDER examples/hl/fortran