summaryrefslogtreecommitdiffstats
path: root/hl/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2023-10-11 20:16:01 (GMT)
committerGitHub <noreply@github.com>2023-10-11 20:16:01 (GMT)
commit85c176247d2c434d9db535999a285daa13aa50b5 (patch)
treef2b7f2864585b3dd019d6f9adbe941d532eacc74 /hl/fortran/examples/CMakeLists.txt
parent6f56d06f6af371b8b8c58079d8200647df249ee2 (diff)
downloadhdf5-85c176247d2c434d9db535999a285daa13aa50b5.zip
hdf5-85c176247d2c434d9db535999a285daa13aa50b5.tar.gz
hdf5-85c176247d2c434d9db535999a285daa13aa50b5.tar.bz2
Address nagfor exceptions stoppage. (#3658)
* added cmake ieee flag for nagfor * generalized determining the nag compiler * fixing some misc. NAG warnings
Diffstat (limited to 'hl/fortran/examples/CMakeLists.txt')
-rw-r--r--hl/fortran/examples/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/hl/fortran/examples/CMakeLists.txt b/hl/fortran/examples/CMakeLists.txt
index 293bc2b..caa5e78 100644
--- a/hl/fortran/examples/CMakeLists.txt
+++ b/hl/fortran/examples/CMakeLists.txt
@@ -10,6 +10,7 @@ foreach (example ${examples})
add_executable (hl_f90_ex_${example} ${HDF5_HL_F90_EXAMPLES_SOURCE_DIR}/${example}.f90)
target_compile_options(hl_f90_ex_${example}
PRIVATE
+ "${HDF5_CMAKE_Fortran_FLAGS}"
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
# set_property(TARGET hl_f90_ex_${example} APPEND PROPERTY LINK_FLAGS $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"-SUBSYSTEM:CONSOLE">)