summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2023-09-07 22:25:07 (GMT)
committerGitHub <noreply@github.com>2023-09-07 22:25:07 (GMT)
commit08e115b7d8f95551be8bede824847997d95d0cf1 (patch)
treea377c6607419278eaafc8cf3043608f93afe1ad7 /hl/fortran/src/CMakeLists.txt
parent8253ab9ebf6a082dc07eb931f27b169d6a45d577 (diff)
downloadhdf5-08e115b7d8f95551be8bede824847997d95d0cf1.zip
hdf5-08e115b7d8f95551be8bede824847997d95d0cf1.tar.gz
hdf5-08e115b7d8f95551be8bede824847997d95d0cf1.tar.bz2
Added new Fortran API wrappers (#3511)
* Added new wrappers for h5get_free_list_sizes_f H5Sselect_intersect_block_f H5Sselect_shape_same_f h5pget_no_selection_io_cause_f h5pget_mpio_no_collective_cause_f H5Lvisit_by_name_f H5Lvisit_f H5Fget_info_f h5dwrite_chunk_f h5dread_chunk_f * added h5pget_file_space_page_size_f, h5pset_file_space_page_size_f, h5pget_file_space_strategy_f, h5pset_file_space_strategy_f, h5info tests * added fortran tests * Update tH5F.F90
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index 0aa0f15..d9f0af2 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -111,6 +111,7 @@ set (HDF5_HL_F90_F_BASE_SOURCES
${HDF5_HL_F90_SRC_SOURCE_DIR}/H5TBff.F90
${HDF5_HL_F90_SRC_SOURCE_DIR}/H5LTff.F90
${HDF5_HL_F90_SRC_SOURCE_DIR}/H5IMff.F90
+ ${HDF5_HL_F90_SRC_SOURCE_DIR}/H5DOff.F90
)
if (BUILD_STATIC_LIBS)
@@ -242,6 +243,7 @@ set (mod_export_files
h5lt.mod
h5lt_const.mod
h5im.mod
+ h5do.mod
)
if (BUILD_STATIC_LIBS)