summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-04-30 14:56:27 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-04-30 14:56:27 (GMT)
commit6fb94eb3a38ea5f6d7253b72f7038ac00f295962 (patch)
tree4969cc08041f2cdb2c2c3fd2f2091920c68c32a5 /hl/fortran/src/CMakeLists.txt
parent76d0cc0ca992e3f373c64ddc578ebfed09c77455 (diff)
downloadhdf5-6fb94eb3a38ea5f6d7253b72f7038ac00f295962.zip
hdf5-6fb94eb3a38ea5f6d7253b72f7038ac00f295962.tar.gz
hdf5-6fb94eb3a38ea5f6d7253b72f7038ac00f295962.tar.bz2
TRILABS-19 fix fortran link flags
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index ffe8f16..bf05a7b 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -168,7 +168,7 @@ set_target_properties (${HDF5_HL_F90_LIB_TARGET} PROPERTIES
FOLDER libraries/hl/fortran
LINKER_LANGUAGE Fortran
Fortran_MODULE_DIRECTORY ${CMAKE_Fortran_MODULE_DIRECTORY}/static
- LINK_FLAGS
+ LINK_FLAGS ""
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"/SUBSYSTEM:CONSOLE">
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_LINK_FLAGS}>
)
@@ -205,7 +205,7 @@ if (BUILD_SHARED_LIBS)
FOLDER libraries/hl/fortran
LINKER_LANGUAGE Fortran
Fortran_MODULE_DIRECTORY ${CMAKE_Fortran_MODULE_DIRECTORY}/shared
- LINK_FLAGS
+ LINK_FLAGS ""
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"/SUBSYSTEM:CONSOLE">
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_LINK_FLAGS}>
)