summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-11 20:28:56 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-02-11 20:28:56 (GMT)
commit4ec2df9ac08f0c28eb32211c3cb0139a73f82981 (patch)
tree5fd3daa9f8168cfb46902bd62ad070c6639796de /hl/fortran/src/CMakeLists.txt
parentbd5d6e4e772fe557ab52f881df17f73a4028184b (diff)
downloadhdf5-4ec2df9ac08f0c28eb32211c3cb0139a73f82981.zip
hdf5-4ec2df9ac08f0c28eb32211c3cb0139a73f82981.tar.gz
hdf5-4ec2df9ac08f0c28eb32211c3cb0139a73f82981.tar.bz2
Merge from dev, sanitizer, fortran, warnings and tools ids
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index e532fff..91ec669 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -164,7 +164,7 @@ if (NOT ONLY_SHARED_LIBS)
PRIVATE
"${HDF5_F90_BINARY_DIR};${CMAKE_Fortran_MODULE_DIRECTORY}/static;$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_Fortran_INCLUDE_DIRS}>"
INTERFACE
- "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
+ "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include/static>"
)
target_compile_definitions(${HDF5_HL_F90_LIB_TARGET}
PUBLIC
@@ -201,7 +201,7 @@ if (BUILD_SHARED_LIBS)
PRIVATE
"${HDF5_F90_BINARY_DIR};${CMAKE_Fortran_MODULE_DIRECTORY}/shared;$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_Fortran_INCLUDE_DIRS}>"
INTERFACE
- "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include>"
+ "$<INSTALL_INTERFACE:$<INSTALL_PREFIX>/include/shared>"
)
target_compile_definitions(${HDF5_HL_F90_LIBSH_TARGET}
PUBLIC