summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-10 14:31:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-10 14:31:44 (GMT)
commit6bf125c7b38887a26b95d3eac4be08e5e44bb1af (patch)
tree3bdf9aeef1edb52fd8fe8c000ec2d3ea346310ea /hl/fortran/src/CMakeLists.txt
parent16e0a6b85868ddc30fffe2c92063f71caa5c71c2 (diff)
downloadhdf5-6bf125c7b38887a26b95d3eac4be08e5e44bb1af.zip
hdf5-6bf125c7b38887a26b95d3eac4be08e5e44bb1af.tar.gz
hdf5-6bf125c7b38887a26b95d3eac4be08e5e44bb1af.tar.bz2
HDFFV-10385 fix fortran references
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index 47e8236..dc2629a 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -37,8 +37,10 @@ set_target_properties (H5HL_buildiface PROPERTIES
)
if (BUILD_SHARED_LIBS)
+ file (MAKE_DIRECTORY "${HDF5_HL_F90_SRC_BINARY_DIR}/shared")
set (MODSH_BUILD_DIR ${CMAKE_Fortran_MODULE_DIRECTORY}/shared/${HDF5_CFG_BUILD_TYPE})
endif ()
+file (MAKE_DIRECTORY "${HDF5_HL_F90_SRC_BINARY_DIR}/static")
set (MOD_BUILD_DIR ${CMAKE_Fortran_MODULE_DIRECTORY}/static/${HDF5_CFG_BUILD_TYPE})
#-----------------------------------------------------------------------------