summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-05-24 21:50:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-05-24 21:50:06 (GMT)
commit336a7430689b067d2ad4632988d534812a08c8de (patch)
tree7e08511924f2ae7b3dfd68df7d7ac059eac7552c /hl/fortran/src/CMakeLists.txt
parent01553cb8f7dca506522b4349043348cccecc318e (diff)
downloadhdf5-336a7430689b067d2ad4632988d534812a08c8de.zip
hdf5-336a7430689b067d2ad4632988d534812a08c8de.tar.gz
hdf5-336a7430689b067d2ad4632988d534812a08c8de.tar.bz2
[svn-r22405] HDFFV-8018: add INSTALL commands for packaging the pdb files for windows when configured with RelWithDebInfo
Tested: local linux and Windows
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index f01c7f8..b6f6d08 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -95,6 +95,10 @@ ENDIF (WIN32 AND NOT CYGWIN)
# Add Target(s) to CMake Install for import into other projects
#-----------------------------------------------------------------------------
IF (HDF5_EXPORTED_TARGETS)
+
+ INSTALL_TARGET_PDB (${HDF5_HL_F90_C_LIB_TARGET} ${HDF5_INSTALL_LIB_DIR} hlfortlibraries)
+ INSTALL_TARGET_PDB (${HDF5_HL_F90_LIB_TARGET} ${HDF5_INSTALL_LIB_DIR} hlfortlibraries)
+
INSTALL (
TARGETS
${HDF5_HL_F90_C_LIB_TARGET}