summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-09-15 20:38:57 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-09-15 20:38:57 (GMT)
commit9af344117c2d41886da1f54d3f5cff4091c4a943 (patch)
tree9dcb6bf61c2fbc5634b69f554690bb740b8decbd /hl/fortran/src/CMakeLists.txt
parentb2f94f9faf805035e4d0e9cb76007204c8250e58 (diff)
parent14e3550348d08d932e0f61a4ae6b8a7afe19a484 (diff)
downloadhdf5-9af344117c2d41886da1f54d3f5cff4091c4a943.zip
hdf5-9af344117c2d41886da1f54d3f5cff4091c4a943.tar.gz
hdf5-9af344117c2d41886da1f54d3f5cff4091c4a943.tar.bz2
[svn-r27794] Reintegration merge of features/autotools_rework branch with trunk
NOTES: - Developers will have to run autogen.sh before building with the autotools. - autogen.sh takes the -p option to mimic the old bin/reconfigure behavior. - The generated error, overflow and version headers have been left in place. - The generated H5LT parser code has also been left in place. - There are no changes for CMake users at this time. Tested on: h5committest
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index ead21be..83a205f 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -48,6 +48,11 @@ if (WIN32)
else (WIN32)
set (MOD_BUILD_DIR ${CMAKE_Fortran_MODULE_DIRECTORY}/static)
endif (WIN32)
+if (WIN32)
+ set (MOD_BUILD_DIR ${CMAKE_Fortran_MODULE_DIRECTORY}/static/\${BUILD_TYPE})
+else (WIN32)
+ set (MOD_BUILD_DIR ${CMAKE_Fortran_MODULE_DIRECTORY}/static)
+endif (WIN32)
#-----------------------------------------------------------------------------
# Setup include Directories