summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-23 20:12:13 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-23 20:12:13 (GMT)
commitf0c4d55f914d3d7ee27703fbeb54c99ffa1603eb (patch)
tree8ab3347ac0b507ebaac505a015b6f24198d2b08c /hl/fortran/src/CMakeLists.txt
parent05a320e9eb464e7b905fcfd4fc3bb4f4d83793ed (diff)
downloadhdf5-f0c4d55f914d3d7ee27703fbeb54c99ffa1603eb.zip
hdf5-f0c4d55f914d3d7ee27703fbeb54c99ffa1603eb.tar.gz
hdf5-f0c4d55f914d3d7ee27703fbeb54c99ffa1603eb.tar.bz2
[svn-r26908] Added missing c_long_double interfaces, now handles promotion of reals and integers to 8 bytes, added C wrappers that take pointers from Fortran.
Diffstat (limited to 'hl/fortran/src/CMakeLists.txt')
-rw-r--r--hl/fortran/src/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/hl/fortran/src/CMakeLists.txt b/hl/fortran/src/CMakeLists.txt
index c5ef916..e52855c 100644
--- a/hl/fortran/src/CMakeLists.txt
+++ b/hl/fortran/src/CMakeLists.txt
@@ -2,6 +2,16 @@ cmake_minimum_required (VERSION 3.1.0)
PROJECT(HDF5_HL_F90_SRC C CXX Fortran)
#-----------------------------------------------------------------------------
+# configure def file for shared libs on windows
+if (WIN32)
+ if (BUILD_SHARED_LIBS)
+ if (MSVC)
+ configure_file (${HDF5_HL_F90_SRC_SOURCE_DIR}/hdf5_hl_fortrandll.def.in ${HDF5_F90_SRC_BINARY_DIR}/hdf5_hl_fortrandll.def @ONLY)
+ endif (MSVC)
+ endif (BUILD_SHARED_LIBS)
+endif (WIN32)
+
+#-----------------------------------------------------------------------------
# Setup include Directories
#-----------------------------------------------------------------------------
INCLUDE_DIRECTORIES (