summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-07 17:59:42 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-07 17:59:42 (GMT)
commit093515817bd8d1bd78944d1f3ee1b90dc4ba9d51 (patch)
tree36cc8a7014e94fad7ed6ed84b36fb1a8b4d42962 /hl/fortran/src/Makefile.am
parent3ca585e46cf4dd53be7eaded5484a9ff496d2312 (diff)
downloadhdf5-093515817bd8d1bd78944d1f3ee1b90dc4ba9d51.zip
hdf5-093515817bd8d1bd78944d1f3ee1b90dc4ba9d51.tar.gz
hdf5-093515817bd8d1bd78944d1f3ee1b90dc4ba9d51.tar.bz2
[svn-r9952] Purpose:
Bug fix Description: Typo in /hl/fortran/src Makefile.am caused obtuse compiler complaints from some compilers (but not others). Errors were of the form: gcc: cannot specify -o with -c or -S and multiple compilations Solution: In AM_CLFAGS, missed -I before ../../hl/src. This made gcc think that we also wanted to compile /hl/src directory. Fixed error by adding -I. Platforms tested: verbena, eirene.
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index b50b239..9153247 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -11,7 +11,7 @@
include $(top_srcdir)/config/commence.am
-AM_CPPFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src $(top_builddir)/hl/src
+AM_CPPFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src -I$(top_builddir)/hl/src
AM_FFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
# Our main target, the high-level fortran library