summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorElena Pourmal <epourmal@hdfgroup.org>2005-06-24 05:00:01 (GMT)
committerElena Pourmal <epourmal@hdfgroup.org>2005-06-24 05:00:01 (GMT)
commit2ab6b12b552e9260e2e76640a788b5a3744c6a9f (patch)
tree6ef872a02a4fd46af33370854af5e7876f4fa29b /hl/fortran/src/Makefile.am
parente38365206ae36d83b8e573eb0b2e51e555699c97 (diff)
downloadhdf5-2ab6b12b552e9260e2e76640a788b5a3744c6a9f.zip
hdf5-2ab6b12b552e9260e2e76640a788b5a3744c6a9f.tar.gz
hdf5-2ab6b12b552e9260e2e76640a788b5a3744c6a9f.tar.bz2
[svn-r10977] Purpose: Bug fix
Description: 1.7 daily tests failed in HL library when Fortran was not enabled; also long long instead of long_long declarations were used and caused failures on Windows Solution: Removed Fortran related functions (except H5IM_find_palette) from H5IM.c file and put it into fortran/src/H5IMcc.c Modified appropriate Makefile.am files, regenerated Makefile.in files, updated header files, MANIFEST, etc. Note: H5IM_find_palette should be also in H5IMcc.c, but for some unknown to me reason, linking fails if the function is included in H5IMcc.c. I will really appreciate if some C guru will look into the code and figure out what is wrong :-) Thanks! Platforms tested: mir with g95, heping with and without Fortran enabled Misc. update:
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 7d06024..1462fbb 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -22,14 +22,14 @@ AM_LDFLAGS=-static
lib_LTLIBRARIES=libhdf5hl_fortran.la
# Source files for the library
-if BUILD_PARALLEL_CONDITIONAL
- PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90
-endif
+#if BUILD_PARALLEL_CONDITIONAL
+# PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90
+#endif
-libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5TBfc.c H5LTff.f90 \
+libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c H5LTff.f90 \
H5IMff.f90 H5TBff.f90
-libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL)
+#libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL)
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules