summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2011-06-10 03:42:34 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2011-06-10 03:42:34 (GMT)
commit7c040a1efb2df6794e7cff27b34e0053ff6dd301 (patch)
tree554cd6f39850b35fba50dad91e5636837ae1956d /hl/fortran/src/Makefile.am
parent5479ee3b0ce741ed7bbae5b90b102f51c18f8b99 (diff)
downloadhdf5-7c040a1efb2df6794e7cff27b34e0053ff6dd301.zip
hdf5-7c040a1efb2df6794e7cff27b34e0053ff6dd301.tar.gz
hdf5-7c040a1efb2df6794e7cff27b34e0053ff6dd301.tar.bz2
[svn-r20958] Description: Added fortran wrappers and test for the HL DS API.
Tested: jam (intel, gnu, pgi)
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index f872a63..9835196 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -46,8 +46,8 @@ endif
#endif
# List sources to include in the HDF5 HL Fortran library.
-libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c H5LTff.f90 \
- H5IMff.f90 H5TBff.f90
+libhdf5hl_fortran_la_SOURCES=H5DSfc.c H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c \
+ H5DSff.f90 H5LTff.f90 H5IMff.f90 H5TBff.f90
# HDF5 HL Fortran library depends on HDF5 HL Library and HDF5 Fortran Library.
libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL) $(LIBH5F)
@@ -79,6 +79,7 @@ uninstall-local:
# determining this automagically (like we do with the C files). So, when
# doing a parallel make, some modules could be made way before the
# modules they depend upon are actually made. *sigh*
+H5DSff.lo: $(srcdir)/H5DSff.f90
H5LTff.lo: $(srcdir)/H5LTff.f90
H5IMff.lo: $(srcdir)/H5IMff.f90
H5TBff.lo: $(srcdir)/H5TBff.f90