summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-01 03:20:11 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-01 03:20:11 (GMT)
commit7e28ae7b47f475ec89f3b78730e3d67bea037397 (patch)
treeae5d8a1b024fde229c77228518004bcffe94e12c /hl/fortran/src/Makefile.am
parent1157fb4eb37e02d7dbd30dbf9779ac167a42d387 (diff)
downloadhdf5-7e28ae7b47f475ec89f3b78730e3d67bea037397.zip
hdf5-7e28ae7b47f475ec89f3b78730e3d67bea037397.tar.gz
hdf5-7e28ae7b47f475ec89f3b78730e3d67bea037397.tar.bz2
[svn-r9904] Purpose:
Configuration update Description: HDF5 now uses automake Solution: Ditto to previous checkin
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
new file mode 100644
index 0000000..22ac0d7
--- /dev/null
+++ b/hl/fortran/src/Makefile.am
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2001 National Center for Supercomputing Applications.
+# All rights reserved.
+#
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+#
+# HDF5 High-Level Fortran Makefile(.in)
+
+include $(top_srcdir)/config/commence.am
+
+AM_CPPFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src $(top_builddir)/hl/src
+AM_FFLAGS=-I$(top_builddir)/fortran/src -M$(top_builddir)/fortran/src
+
+# Our main target, the high-level fortran library
+lib_LTLIBRARIES=libhdf5hl_fortran.la
+
+# Source files for the library
+if BUILD_PARALLEL_CONDITIONAL
+ PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90
+endif
+
+libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5TBfc.c H5LTff.f90 \
+ H5IMff.f90 H5TBff.f90
+
+libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL)
+
+# Fortran module files can have different extensions and different names
+# (e.g., different capitalizations) on different platforms. Write rules
+# for them explicitly rather than trying to teach automake about them.
+# They should be installed as headers and removed during clean.
+maintainer-clean-local: clean-local
+distclean-local: clean-local
+clean-local:
+ if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(RM) *.$(F9XMODEXT); \
+ fi
+
+install-data-local:
+ if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ fi
+
+uninstall-local:
+ if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
+ if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
+ set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
+ fi; \
+ fi
+
+# Hardcode the dependencies of these files. There isn't a known way of
+# determining this automagically (like we do with the C files). So, when
+# doing a parallel make, some modules could be made way before the
+# modules they depend upon are actually made. *sigh*
+H5LTff.lo: $(srcdir)/H5LTff.f90
+H5IMff.lo: $(srcdir)/H5IMff.f90
+H5TBff.lo: $(srcdir)/H5TBff.f90
+
+include $(top_srcdir)/config/conclude.am