summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2013-09-24 01:14:24 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2013-09-24 01:14:24 (GMT)
commitab239810e1ae81f390a91dfbb3e5d68934efee55 (patch)
treeace4b146b778237765c69c6fb0288c4f6ba4081c /hl/fortran/src/Makefile.am
parentc19d87b1fc55a3c89bbcea6d940e4b50a4961ef4 (diff)
downloadhdf5-ab239810e1ae81f390a91dfbb3e5d68934efee55.zip
hdf5-ab239810e1ae81f390a91dfbb3e5d68934efee55.tar.gz
hdf5-ab239810e1ae81f390a91dfbb3e5d68934efee55.tar.bz2
[svn-r24194] Don't add hdf5 library dependencies to lib files when --disable-sharedlib-rpath configure option is invoked. Fix for HDFFV-8276.
Tested with h5committest and on hdf-duck.
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 9835196..edc5895 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -49,8 +49,11 @@ endif
libhdf5hl_fortran_la_SOURCES=H5DSfc.c H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c \
H5DSff.f90 H5LTff.f90 H5IMff.f90 H5TBff.f90
-# HDF5 HL Fortran library depends on HDF5 HL Library and HDF5 Fortran Library.
+# HDF5 HL Fortran library depends on HDF5 Library. However, only add the dependency
+# if --enable-sharedlib-rpath is yes.
+if LT_ADD_LIBHDF5_DEPENDENCY
libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL) $(LIBH5F)
+endif
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules