summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-07-08 22:09:50 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-07-08 22:09:50 (GMT)
commitb0afa2ab6157cf9519ce3fffccd40770157de214 (patch)
treeaf1431881fab22af8ddbf0d9ba124476a3e6f185 /hl/fortran/src/Makefile.am
parent5ed3e8a4a773d59b9d8c731551bf7ede05de0fd2 (diff)
downloadhdf5-b0afa2ab6157cf9519ce3fffccd40770157de214.zip
hdf5-b0afa2ab6157cf9519ce3fffccd40770157de214.tar.gz
hdf5-b0afa2ab6157cf9519ce3fffccd40770157de214.tar.bz2
[svn-r27355] added generation of HL Fortran Interfaces for REALs
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 0668230..bbb6c6b 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -46,8 +46,10 @@ endif
#endif
# List sources to include in the HDF5 HL Fortran library.
-libhdf5hl_fortran_la_SOURCES=H5DSfc.c H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c \
- H5DSff.F90 H5LTff.F90 H5IMff.F90 H5TBff.F90
+libhdf5hl_fortran_la_SOURCES=H5DSfc.c H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c \
+ H5DSff.F90 H5LTff.F90 H5IMff.F90 H5TBff.F90 H5LTff_gen.F90 H5TBff_gen.F90
+
+#H5LTff_gen.F90 H5TBff_gen.F90
# HDF5 HL Fortran library depends on HDF5 Library.
libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL) $(LIBH5F)
@@ -60,7 +62,7 @@ maintainer-clean-local: clean-local
distclean-local: clean-local
clean-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(RM) *.$(F9XMODEXT); \
+ $(RM) *.$(F9XMODEXT) H5LTff_gen.F90 H5TBff_gen.F90; \
fi
install-data-local:
@@ -75,6 +77,23 @@ uninstall-local:
fi; \
fi
+# These are the helper programs we need to build.
+noinst_PROGRAMS = H5HL_buildiface
+
+# H5HL_buildiface.F90 generates all the APIs that have a KIND type associated
+# with them.
+
+H5LTff_gen.F90: H5HL_buildiface$(EXEEXT)
+ $(RUNSERIAL) ./H5HL_buildiface$(EXEEXT)
+
+H5TBff_gen.F90: H5HL_buildiface$(EXEEXT)
+
+#H5TBff_gen.F90: H5HL_buildiface$(EXEEXT)
+
+# H5HL_buildiface.F90 is included in the distribution, and Automake knows
+# how to compile a fortran program given its sources.
+
+H5HL_buildiface_SOURCES = H5HL_buildiface.F90
# Hardcode the dependencies of these files. There isn't a known way of
# determining this automagically (like we do with the C files). So, when
# doing a parallel make, some modules could be made way before the
@@ -83,5 +102,6 @@ H5DSff.lo: $(srcdir)/H5DSff.F90
H5LTff.lo: $(srcdir)/H5LTff.F90
H5IMff.lo: $(srcdir)/H5IMff.F90
H5TBff.lo: $(srcdir)/H5TBff.F90
-
+H5LTff_gen.lo: H5LTff_gen.F90
+H5TBff_gen.lo: H5LTff_gen.F90 H5TBff_gen.F90
include $(top_srcdir)/config/conclude.am