summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
commitc63ef2cba28df827eb090a019284c7cd8c2982af (patch)
tree134ff7254d8ee7b1c6f7fa3eabc509528899d68d /hl/fortran/src/Makefile.am
parentf2240792704b74fc288b4e4a570509c4afe4a34e (diff)
downloadhdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.zip
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.gz
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.bz2
[svn-r11179] Purpose:
Feature: check-clean target Description: 'make check-clean' cleans up output files from tests. Solution: Tests create foo.chkexe and foo.log files. Scripts create foo.chksh and foo.logsh files. 'make check-clean' will clean these files up so that the tests can be re-run. Also suppressed some not-very-useful output of Makefiles when it would echo commands. Platforms tested: mir, sleipnir, modi4 Misc. update:
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 1462fbb..14076e7 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -29,8 +29,6 @@ lib_LTLIBRARIES=libhdf5hl_fortran.la
libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c H5LTff.f90 \
H5IMff.f90 H5TBff.f90
-#libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL)
-
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules
# for them explicitly rather than trying to teach automake about them.
@@ -38,17 +36,17 @@ libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c H5LTff.f90 \
maintainer-clean-local: clean-local
distclean-local: clean-local
clean-local:
- if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
$(RM) *.$(F9XMODEXT); \
fi
install-data-local:
- if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
+ @if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
$(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
fi
uninstall-local:
- if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
+ @if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
fi; \