summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-26 22:28:23 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-26 22:28:23 (GMT)
commitd7883f21bf2d0d4b7b21397b42520a381364f30f (patch)
tree66d858b5a1b1d44f2db1e7f3b240eb679fcf8367 /hl/fortran/src/Makefile.am
parenta9b7b7d971cc714e09647794a2d688463c507666 (diff)
downloadhdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.zip
hdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.tar.gz
hdf5-d7883f21bf2d0d4b7b21397b42520a381364f30f.tar.bz2
[svn-r10098] Purpose:
Bug fix Description: Some machines and compilers were having trouble creating fortran libraries as shared libraries. Solution: Added flag in Makefiles.am to create fortran libraries as shared libraries. (This is how HDF5 was set up before automake changes; I forgot to add these flags, and it didn't cause a problem until now.) Platforms tested: sleipnir, eirene, verbena Misc. update:
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 9153247..994ccaa 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -17,6 +17,9 @@ AM_FFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
# Our main target, the high-level fortran library
lib_LTLIBRARIES=libhdf5hl_fortran.la
+# Fortran library is linked statically to solve a build problem.
+libhdf5hl_fortran_la_LDFLAGS=-static
+
# Source files for the library
if BUILD_PARALLEL_CONDITIONAL
PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90