summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-10-08 20:56:21 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-10-08 20:56:21 (GMT)
commita59735101d4a0a9a5505b8aad0d0ceb9d0119715 (patch)
treed5b70f427a5fc7fd1835b1721589a878ae5703fc /hl/fortran/src/Makefile.am
parentda42cfa2c453e6664d35ee84cc0d4ca9abbc6779 (diff)
downloadhdf5-a59735101d4a0a9a5505b8aad0d0ceb9d0119715.zip
hdf5-a59735101d4a0a9a5505b8aad0d0ceb9d0119715.tar.gz
hdf5-a59735101d4a0a9a5505b8aad0d0ceb9d0119715.tar.bz2
[svn-r15822] Bug fix: #1090
The custom rules for installing h5cc, h5fc, and the fortran modules in fortran and in hl/fortran don't use $(DESTDIR). Added it to all those rules. Tested: kagiso both serial and parallel with fortran and cxx enabled. Tested by: make install make DESTDIR=/tmp/acheng install diff -r /tmp/acheng/.../hdf5 hdf5
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 0285412..6bf010b 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -57,12 +57,12 @@ clean-local:
install-data-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
fi
uninstall-local:
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
- if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
+ if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(DESTDIR)$(includedir)/HDF5.$(F9XMODEXT)"; then \
set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
fi; \
fi