summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:00:11 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:00:11 (GMT)
commitbc36a358d115d1cddc7328e61a44558c023d20fd (patch)
treef4c8f79102fc8decb73d04c8706418216a0676a8 /hl/fortran/src/Makefile.am
parent476cbeda792322fb66600eeb7022d303bd55d7c7 (diff)
downloadhdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.zip
hdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.tar.gz
hdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.tar.bz2
[svn-r16792] Description:
- Updated bin/reconfigure to use latest version of automake (1.10.2). Re-generated Makefile.in's by running bin/reconfigure. - Added libtool version numbers to c++, fortran, hl, hl c++, and hl fortran libraries. Tested: jam, liberty, smirom
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 6bf010b..fbc3908 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -20,6 +20,7 @@
# HDF5 High-Level Fortran Makefile(.in)
include $(top_srcdir)/config/commence.am
+include $(top_srcdir)/config/lt_vers.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src -I$(top_builddir)/hl/src \
-I$(top_srcdir)/fortran/src -I$(top_builddir)/fortran/src
@@ -28,6 +29,9 @@ AM_FCFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/sr
# Our main target, the high-level fortran library
lib_LTLIBRARIES=libhdf5hl_fortran.la
+# Add libtool numbers to the HDF5 HL Fortran library (from config/lt_vers.am)
+libhdf5hl_fortran_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+
# Some Fortran compilers can't build shared libraries, so sometimes we
# want to build a shared C library and a static Fortran library. If so,
# pass the -static flag to the library linker.