summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
commitc6e3e682973aa793844e39376cb7ada93ce505ba (patch)
tree190929e40042c15843c28d591a1c0e336c743dc4 /hl/fortran/src/Makefile.am
parent7309bb5ab8810a701d5aa98c8068b98792585d9a (diff)
downloadhdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.zip
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.gz
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.bz2
[svn-r25117] Removed LT_ADD_LIBHDF5_DEPENDENCY configure conditional to roll back fix for removing rpaths from l
ib files. The fix also removed dependencies on libhdf5, etc. when the --disable-sharedlib-rpath co nfigure option was invoked. Added instead configure variable hardcode_into_lib=no. This removes rpath from lib files on Linux and solaris machines. Tested with h5committest on jam, koala, ostrich and platypus (cmake), and with configure option --disable-sharedlib-rpath on emu, platypus and quail.
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 5195371..c8c4541 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -49,11 +49,8 @@ endif
libhdf5hl_fortran_la_SOURCES=H5DSfc.c H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c \
H5DSff.f90 H5LTff.f90 H5IMff.f90 H5TBff.f90
-# HDF5 HL Fortran library depends on HDF5 Library. However, only add the dependency
-# if --enable-sharedlib-rpath is yes.
-if LT_ADD_LIBHDF5_DEPENDENCY
+# HDF5 HL Fortran library depends on HDF5 Library.
libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL) $(LIBH5F)
-endif
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules