summaryrefslogtreecommitdiffstats
path: root/hl/fortran/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-06-10 14:52:54 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-06-10 14:52:54 (GMT)
commita2f0603135d8311520f2f7345bd9a78d124f26c8 (patch)
treebd0c08435a208134b02b1eedc853215e051a972d /hl/fortran/test/CMakeLists.txt
parent864a502671cefa001b6d7417389fc4a265cf8516 (diff)
downloadhdf5-a2f0603135d8311520f2f7345bd9a78d124f26c8.zip
hdf5-a2f0603135d8311520f2f7345bd9a78d124f26c8.tar.gz
hdf5-a2f0603135d8311520f2f7345bd9a78d124f26c8.tar.bz2
[svn-r20960] Added new source files.
Added new test and test files to test section Tested: local linux
Diffstat (limited to 'hl/fortran/test/CMakeLists.txt')
-rw-r--r--hl/fortran/test/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/hl/fortran/test/CMakeLists.txt b/hl/fortran/test/CMakeLists.txt
index 0a91b85..470aab9 100644
--- a/hl/fortran/test/CMakeLists.txt
+++ b/hl/fortran/test/CMakeLists.txt
@@ -20,6 +20,15 @@ ADD_TEST (
f1tab.h5
)
+#-- Adding test for hl_f90_tstds
+ADD_EXECUTABLE (hl_f90_tstds tstds.f90)
+TARGET_NAMING (hl_f90_tstds ${LIB_TYPE})
+TARGET_FORTRAN_WIN_PROPERTIES (hl_f90_tstds "")
+TARGET_LINK_LIBRARIES (hl_f90_tstds ${HDF5_HL_F90_LIB_TARGET} ${HDF5_F90_LIB_TARGET})
+SET_TARGET_PROPERTIES (hl_f90_tstds PROPERTIES LINKER_LANGUAGE Fortran)
+
+ADD_TEST (NAME hl_f90_tstds COMMAND $<TARGET_FILE:hl_f90_tstds>)
+
#-- Adding test for hl_f90_tstlite
ADD_EXECUTABLE (hl_f90_tstlite tstlite.f90)
TARGET_NAMING (hl_f90_tstlite ${LIB_TYPE})