summaryrefslogtreecommitdiffstats
path: root/hl/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorElena Pourmal <epourmal@hdfgroup.org>2005-06-24 05:00:01 (GMT)
committerElena Pourmal <epourmal@hdfgroup.org>2005-06-24 05:00:01 (GMT)
commit2ab6b12b552e9260e2e76640a788b5a3744c6a9f (patch)
tree6ef872a02a4fd46af33370854af5e7876f4fa29b /hl/fortran/test/Makefile.am
parente38365206ae36d83b8e573eb0b2e51e555699c97 (diff)
downloadhdf5-2ab6b12b552e9260e2e76640a788b5a3744c6a9f.zip
hdf5-2ab6b12b552e9260e2e76640a788b5a3744c6a9f.tar.gz
hdf5-2ab6b12b552e9260e2e76640a788b5a3744c6a9f.tar.bz2
[svn-r10977] Purpose: Bug fix
Description: 1.7 daily tests failed in HL library when Fortran was not enabled; also long long instead of long_long declarations were used and caused failures on Windows Solution: Removed Fortran related functions (except H5IM_find_palette) from H5IM.c file and put it into fortran/src/H5IMcc.c Modified appropriate Makefile.am files, regenerated Makefile.in files, updated header files, MANIFEST, etc. Note: H5IM_find_palette should be also in H5IMcc.c, but for some unknown to me reason, linking fails if the function is included in H5IMcc.c. I will really appreciate if some C guru will look into the code and figure out what is wrong :-) Thanks! Platforms tested: mir with g95, heping with and without Fortran enabled Misc. update:
Diffstat (limited to 'hl/fortran/test/Makefile.am')
-rw-r--r--hl/fortran/test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hl/fortran/test/Makefile.am b/hl/fortran/test/Makefile.am
index bbff539..8597e1f 100644
--- a/hl/fortran/test/Makefile.am
+++ b/hl/fortran/test/Makefile.am
@@ -11,7 +11,7 @@
include $(top_srcdir)/config/commence.am
-AM_CPPFLAGS=-I$(top_srcdir)/src $(top_builddir)/src
+AM_CPPFLAGS=-I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/hl/src
AM_FCFLAGS=-I$(top_builddir)/fortran/src -I$(top_builddir)/hl/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/hl/fortran/src
# Fortran libraries are linked statically to solve a build problem.
@@ -21,7 +21,7 @@ AM_LDFLAGS=-static
TEST_PROG=tstlite tstimage tsttable
check_PROGRAMS=$(TEST_PROG)
-LDADD=$(LIBH5_HL) $(LIBH5F_HL) $(LIBH5F) $(LIBHDF5)
+LDADD= $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
# Source files for the programs
tstlite_SOURCES=tstlite.f90