summaryrefslogtreecommitdiffstats
path: root/hl/fortran/test/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2011-06-10 03:42:34 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2011-06-10 03:42:34 (GMT)
commit7c040a1efb2df6794e7cff27b34e0053ff6dd301 (patch)
tree554cd6f39850b35fba50dad91e5636837ae1956d /hl/fortran/test/Makefile.am
parent5479ee3b0ce741ed7bbae5b90b102f51c18f8b99 (diff)
downloadhdf5-7c040a1efb2df6794e7cff27b34e0053ff6dd301.zip
hdf5-7c040a1efb2df6794e7cff27b34e0053ff6dd301.tar.gz
hdf5-7c040a1efb2df6794e7cff27b34e0053ff6dd301.tar.bz2
[svn-r20958] Description: Added fortran wrappers and test for the HL DS API.
Tested: jam (intel, gnu, pgi)
Diffstat (limited to 'hl/fortran/test/Makefile.am')
-rw-r--r--hl/fortran/test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/hl/fortran/test/Makefile.am b/hl/fortran/test/Makefile.am
index 7f149c8..cd281b7 100644
--- a/hl/fortran/test/Makefile.am
+++ b/hl/fortran/test/Makefile.am
@@ -33,18 +33,19 @@ else
endif
# Our main target, the test programs
-TEST_PROG=tstlite tstimage tsttable
+TEST_PROG=tstds tstlite tstimage tsttable
check_PROGRAMS=$(TEST_PROG)
LDADD= $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
# Source files for the programs
+tstds_SOURCES=tstds.f90
tstlite_SOURCES=tstlite.f90
tstimage_SOURCES=tstimage.f90
tsttable_SOURCES=tsttable.f90
# Temporary files.
-CHECK_CLEANFILES+=dsetf[1-4].h5 f1img.h5 f1tab.h5
+CHECK_CLEANFILES+=dsetf[1-4].h5 f1img.h5 f1tab.h5 tstds.h5
# Mark this directory as part of the Fortran API (this affects output
# from tests in conclude.am)