summaryrefslogtreecommitdiffstats
path: root/hl/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-03-18 16:55:05 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-03-18 16:55:05 (GMT)
commit44fe3cc19b4e40672f1d7ab4fcd9cd58ded234e8 (patch)
tree5ae58a9a9d5bb892bf6a80a11facb18b47a67dc6 /hl/src/CMakeLists.txt
parent03d10edd23ce76e9389b54be138ef1bbb8791cef (diff)
downloadhdf5-44fe3cc19b4e40672f1d7ab4fcd9cd58ded234e8.zip
hdf5-44fe3cc19b4e40672f1d7ab4fcd9cd58ded234e8.tar.gz
hdf5-44fe3cc19b4e40672f1d7ab4fcd9cd58ded234e8.tar.bz2
[svn-r24826] HDFFV-8700 -
KitWare recommendations: Change CMake commands to lower case. Bump up CMake minimum versions. Split test file into separate file for h5repack test. Tested: local linux
Diffstat (limited to 'hl/src/CMakeLists.txt')
-rw-r--r--hl/src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/hl/src/CMakeLists.txt b/hl/src/CMakeLists.txt
index e93a23a..e3a72e4 100644
--- a/hl/src/CMakeLists.txt
+++ b/hl/src/CMakeLists.txt
@@ -59,8 +59,9 @@ install (
# Add Target(s) to CMake Install for import into other projects
#-----------------------------------------------------------------------------
if (HDF5_EXPORTED_TARGETS)
-
- INSTALL_TARGET_PDB (${HDF5_HL_LIB_TARGET} ${HDF5_INSTALL_LIB_DIR} hllibraries)
+ if (BUILD_SHARED_LIBS)
+ INSTALL_TARGET_PDB (${HDF5_HL_LIB_TARGET} ${HDF5_INSTALL_LIB_DIR} hllibraries)
+ endif (BUILD_SHARED_LIBS)
install (
TARGETS