summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-25 19:34:54 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-25 19:34:54 (GMT)
commitb018ba48ced579975e60362e3acfb6afb1f1d384 (patch)
tree6aa56f1b84f2a5734964a72faefc33280e3cce47 /hl/src/Makefile.am
parentbbaec6dfe44e8878345de2594dc97f1bc8d361ba (diff)
downloadhdf5-b018ba48ced579975e60362e3acfb6afb1f1d384.zip
hdf5-b018ba48ced579975e60362e3acfb6afb1f1d384.tar.gz
hdf5-b018ba48ced579975e60362e3acfb6afb1f1d384.tar.bz2
[svn-r25106] Removed LT_ADD_LIBHDF5_DEPENDENCY configure conditional to roll back fix for removing rpaths from lib files. The fix also removed dependencies on libhdf5, etc. when the --disable-sharedlib-rpath configure option was invoked.
Added instead configure variable hardcode_into_lib=no. This removes rpath from lib files on Linux and solaris machines. Tested with h5committest on jam, koala, ostrich and platypus (cmake), and on emu and kite.
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 34245ee..09c24dc 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -33,11 +33,8 @@ libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(
# List sources to include in the HDF5 HL Library.
libhdf5_hl_la_SOURCES=H5DO.c H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
-# HDF5 HL library depends on HDF5 Library. However, only add the dependency
-# if --enable-sharedlib-rpath is yes.
-if LT_ADD_LIBHDF5_DEPENDENCY
+# HDF5 HL library depends on HDF5 Library.
libhdf5_hl_la_LIBADD=$(LIBHDF5)
-endif
# Public header files (to be installed)
include_HEADERS=hdf5_hl.h H5DOpublic.h H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h