summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-11-15 19:20:06 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-11-15 19:20:06 (GMT)
commit0efd9ceadfe08f8d706c4f7c41bc60c4f11b35eb (patch)
tree4885cf448f46baf7038b84254af5daee0f2c4e3b /hl/src/Makefile.am
parent5b83c94b9e822fde35107d30150ab47eebe20d15 (diff)
downloadhdf5-0efd9ceadfe08f8d706c4f7c41bc60c4f11b35eb.zip
hdf5-0efd9ceadfe08f8d706c4f7c41bc60c4f11b35eb.tar.gz
hdf5-0efd9ceadfe08f8d706c4f7c41bc60c4f11b35eb.tar.bz2
[svn-r11726] Purpose:
Bug fix Description: Fixed bug in hl/src Makefile that was deleting y.tab.c. Running bin/reconfigure changed a few other files as well (somebody probably updated Makefiles.am but forgot to bin/reconfigure). Solution: Automake in its wisdom adds the line "rm *.tab.c" to every distclean in every directory. I assume that it assumes that such files are generated during the build. Supplied an empty distclean-compile target to remove this line from the Makefiles.in. Platforms tested: mir, sleipnir, shanti
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index a1ff4bf..b7410fe 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -30,4 +30,8 @@ libhdf5_hl_la_SOURCES=H5LT.c H5TB.c H5IM.c H5DS.c H5PT.c H5HL_private.c y.tab.c
# Public header files (to be installed)
include_HEADERS=H5IM.h H5LT.h H5TB.h H5DS.h H5PT.h y.tab.h
+# Automake naturally assumes that we want it to remove y.tab.c on distclean.
+# Convince it otherwise.
+distclean-compile:
+
include $(top_srcdir)/config/conclude.am