summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2005-11-03 14:11:09 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2005-11-03 14:11:09 (GMT)
commit47b0c3b356cca31ffae47c86dc4ebd649ce6bef6 (patch)
tree1306b6407ab049d50ffbcfbfc9b450924d7e5713 /hl/src/Makefile.am
parent7fd6ff2413d3ecf65e77c9474f410a7acb9f4e52 (diff)
downloadhdf5-47b0c3b356cca31ffae47c86dc4ebd649ce6bef6.zip
hdf5-47b0c3b356cca31ffae47c86dc4ebd649ce6bef6.tar.gz
hdf5-47b0c3b356cca31ffae47c86dc4ebd649ce6bef6.tar.bz2
[svn-r11676] Purpose: New feature
Description: Adding the new function H5LTtext_to_dtype() for converting text description to data type. The next step will be H5LTdtype_to_text(). Solution: Use Lex and Yacc to do parsing of the text. H5LTanalyze.l is the lexer for analyzing the input; H5LTparse.y is the parser. They are not part of HL library, but are used to generate lex.yy.c (from H5LTanalyze.l) as well as y.tab.c and y.tab.h (from H5LTparse.y). The tools used to create these source files are GNU FLEX and YACC on a Linux machine (fuss). The commands are "lex H5LTanalyze.l" and "yacc -d H5LTparse.y". Detailed document will be added later. Platforms tested: h5committest and fuss. Misc. update: MANIFEST
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 3360ebe..a1ff4bf 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -25,9 +25,9 @@ AM_CPPFLAGS=-I$(top_srcdir)/src
# This library is our main target.
lib_LTLIBRARIES=libhdf5_hl.la
-libhdf5_hl_la_SOURCES=H5LT.c H5TB.c H5IM.c H5DS.c H5PT.c H5HL_private.c
+libhdf5_hl_la_SOURCES=H5LT.c H5TB.c H5IM.c H5DS.c H5PT.c H5HL_private.c y.tab.c lex.yy.c
# Public header files (to be installed)
-include_HEADERS=H5IM.h H5LT.h H5TB.h H5DS.h H5PT.h
+include_HEADERS=H5IM.h H5LT.h H5TB.h H5DS.h H5PT.h y.tab.h
include $(top_srcdir)/config/conclude.am