summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2011-04-14 21:21:59 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2011-04-14 21:21:59 (GMT)
commit98362b664c5299950edaa85448b219b372106b0b (patch)
treea5d95898916b57abc11b6dab2e53683be55ca31a /hl/src/Makefile.am
parenta45c7424b2d849c8876d4681d0815367f6e5c7f6 (diff)
downloadhdf5-98362b664c5299950edaa85448b219b372106b0b.zip
hdf5-98362b664c5299950edaa85448b219b372106b0b.tar.gz
hdf5-98362b664c5299950edaa85448b219b372106b0b.tar.bz2
[svn-r20504] Purpose:
General shared library improvements for CYGWIN / AIX Description: Shared libraries are disabled on both CYGWIN and AIX due to inability to build them correctly. Part of the problem in both of these situations is the lack of the libtool flag -no-undefined, which tells libtool that all needed symbols are defined at link time (a requirement on these systems) and that it's okay to build shared libraries. Another problem are lack of dependencies between wrapper libraries and core C HDF5 library. This patch addresses both of these by fixing configure to add in -no-undefined flag for libtool during linking and adds automake dependencies in the Makefile.am files. After testing, both CYGWIN and AIX now generate shared libraries, but there are still some test failures in each. (cache_api, dt_arith, and testerror.sh on CYGWIN, and fortran tests on AIX). Even though the shared libraries are not quite perfect, this is a general improvement to what we had before, so I'm applying the patch anyways. Note that default behavior of shared libraries on these systems being disabled has NOT been changed and requires the use of the --enable-unsupported to attempt to build them. We will need to address the test failures in each architecture prior to formally supporting shared libraries on each. Tested: h5committested & CYGWIN tested (on bangan) (AIX tested by Albert on bp-login2)
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 0eecbbb..f3d09ab 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -30,8 +30,12 @@ lib_LTLIBRARIES=libhdf5_hl.la
# Add libtool numbers to the HDF5 hl library (from config/lt_vers.am)
libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
+# List sources to include in the HDF5 HL Library.
libhdf5_hl_la_SOURCES=H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
+# HDF5 HL library depends on HDF5 Library.
+libhdf5_hl_la_LIBADD=$(LIBHDF5)
+
# Public header files (to be installed)
include_HEADERS=hdf5_hl.h H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h