summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2013-09-24 01:14:24 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2013-09-24 01:14:24 (GMT)
commitab239810e1ae81f390a91dfbb3e5d68934efee55 (patch)
treeace4b146b778237765c69c6fb0288c4f6ba4081c /hl/src/Makefile.am
parentc19d87b1fc55a3c89bbcea6d940e4b50a4961ef4 (diff)
downloadhdf5-ab239810e1ae81f390a91dfbb3e5d68934efee55.zip
hdf5-ab239810e1ae81f390a91dfbb3e5d68934efee55.tar.gz
hdf5-ab239810e1ae81f390a91dfbb3e5d68934efee55.tar.bz2
[svn-r24194] Don't add hdf5 library dependencies to lib files when --disable-sharedlib-rpath configure option is invoked. Fix for HDFFV-8276.
Tested with h5committest and on hdf-duck.
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 1e781a9..34245ee 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -33,8 +33,11 @@ libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(
# List sources to include in the HDF5 HL Library.
libhdf5_hl_la_SOURCES=H5DO.c H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
-# HDF5 HL library depends on HDF5 Library.
+# HDF5 HL library depends on HDF5 Library. However, only add the dependency
+# if --enable-sharedlib-rpath is yes.
+if LT_ADD_LIBHDF5_DEPENDENCY
libhdf5_hl_la_LIBADD=$(LIBHDF5)
+endif
# Public header files (to be installed)
include_HEADERS=hdf5_hl.h H5DOpublic.h H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h