summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:00:11 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:00:11 (GMT)
commitbc36a358d115d1cddc7328e61a44558c023d20fd (patch)
treef4c8f79102fc8decb73d04c8706418216a0676a8 /hl/src/Makefile.am
parent476cbeda792322fb66600eeb7022d303bd55d7c7 (diff)
downloadhdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.zip
hdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.tar.gz
hdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.tar.bz2
[svn-r16792] Description:
- Updated bin/reconfigure to use latest version of automake (1.10.2). Re-generated Makefile.in's by running bin/reconfigure. - Added libtool version numbers to c++, fortran, hl, hl c++, and hl fortran libraries. Tested: jam, liberty, smirom
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 37bff7b..3ee186e 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -19,6 +19,7 @@
#
include $(top_srcdir)/config/commence.am
+include $(top_srcdir)/config/lt_vers.am
# Add include directories to the C preprocessor flags
AM_CPPFLAGS=-I$(top_srcdir)/src
@@ -26,6 +27,9 @@ AM_CPPFLAGS=-I$(top_srcdir)/src
# This library is our main target.
lib_LTLIBRARIES=libhdf5_hl.la
+# Add libtool numbers to the HDF5 hl library (from config/lt_vers.am)
+libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+
libhdf5_hl_la_SOURCES=H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
# Public header files (to be installed)