summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorPedro Vicente Nunes <pvn@hdfgroup.org>2006-04-12 21:21:38 (GMT)
committerPedro Vicente Nunes <pvn@hdfgroup.org>2006-04-12 21:21:38 (GMT)
commitbc66efc788bc77c9c133a9fc3cc29e26fa659bab (patch)
treed94f011f1813b4bc479a74f29048418c83f86d02 /hl/src/Makefile.am
parent3dfec8d73b65c5c715581e41844e075b84e8f581 (diff)
downloadhdf5-bc66efc788bc77c9c133a9fc3cc29e26fa659bab.zip
hdf5-bc66efc788bc77c9c133a9fc3cc29e26fa659bab.tar.gz
hdf5-bc66efc788bc77c9c133a9fc3cc29e26fa659bab.tar.bz2
[svn-r12229] Purpose:
new feature Description: 1) separated the HL library into "public" and "private" header files, with the same caracteristics as the basic library 2) added the public headers to hdf5.h (with a conditional include macro, defined in configure.in) 3) added the path to HL in all Makefile.am 's , because of the inclusion in hdf5.h Solution: Platforms tested: linux 32, 64 AIX solaris with fortran and c++ (one packet table example fails) Misc. update:
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 002438d..e8e5588 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -25,10 +25,10 @@ AM_CPPFLAGS=-I$(top_srcdir)/src
# This library is our main target.
lib_LTLIBRARIES=libhdf5_hl.la
-libhdf5_hl_la_SOURCES=H5LT.c H5TB.c H5IM.c H5DS.c H5PT.c H5HL_private.c H5LTparse.c H5LTanalyze.c
+libhdf5_hl_la_SOURCES=H5LT.c H5TB.c H5IM.c H5DS.c H5PT.c H5LTparse.c H5LTanalyze.c
# Public header files (to be installed)
-include_HEADERS=H5IM.h H5LT.h H5TB.h H5DS.h H5PT.h H5LTparse.h
+include_HEADERS=H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h H5LTparse.h
# Automake naturally assumes that we want it to remove H5LTparse.c on distclean.
# Convince it otherwise.