summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-25 21:59:53 (GMT)
commitc6e3e682973aa793844e39376cb7ada93ce505ba (patch)
tree190929e40042c15843c28d591a1c0e336c743dc4 /hl/src/Makefile.am
parent7309bb5ab8810a701d5aa98c8068b98792585d9a (diff)
downloadhdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.zip
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.gz
hdf5-c6e3e682973aa793844e39376cb7ada93ce505ba.tar.bz2
[svn-r25117] Removed LT_ADD_LIBHDF5_DEPENDENCY configure conditional to roll back fix for removing rpaths from l
ib files. The fix also removed dependencies on libhdf5, etc. when the --disable-sharedlib-rpath co nfigure option was invoked. Added instead configure variable hardcode_into_lib=no. This removes rpath from lib files on Linux and solaris machines. Tested with h5committest on jam, koala, ostrich and platypus (cmake), and with configure option --disable-sharedlib-rpath on emu, platypus and quail.
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 34245ee..1e781a9 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -33,11 +33,8 @@ libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(
# List sources to include in the HDF5 HL Library.
libhdf5_hl_la_SOURCES=H5DO.c H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
-# HDF5 HL library depends on HDF5 Library. However, only add the dependency
-# if --enable-sharedlib-rpath is yes.
-if LT_ADD_LIBHDF5_DEPENDENCY
+# HDF5 HL library depends on HDF5 Library.
libhdf5_hl_la_LIBADD=$(LIBHDF5)
-endif
# Public header files (to be installed)
include_HEADERS=hdf5_hl.h H5DOpublic.h H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h