summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2016-03-09 18:55:31 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2016-03-09 18:55:31 (GMT)
commitf5234cd194837790662e0b634fd6236137177674 (patch)
tree8e7408ae73b2db8ae48eb4ee697a60f8187a6659 /hl/src/Makefile.am
parent23e97565cfb9adf329315635fb58553b14670b47 (diff)
downloadhdf5-f5234cd194837790662e0b634fd6236137177674.zip
hdf5-f5234cd194837790662e0b634fd6236137177674.tar.gz
hdf5-f5234cd194837790662e0b634fd6236137177674.tar.bz2
[svn-r29379] Add individual LT_VERS_* variables for wrapper libraries: c++, fortran, java, hl, hl/c++, hl/fortran to so that the shared object version numbers can be incremented independently.
Disabled auto-increment of shared object version numbers by h5vers. Files modified: config/lt_vers.am java/src/jni/Makefile.am hl/src/Makefile.am hl/c++/src/Makefile.am hl/fortran/src/Makefile.am c++/src/Makefile.am bin/h5vers fortran/src/Makefile.am
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 1e781a9..e772233 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -28,7 +28,7 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src
lib_LTLIBRARIES=libhdf5_hl.la
# Add libtool numbers to the HDF5 hl library (from config/lt_vers.am)
-libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
+libhdf5_hl_la_LDFLAGS= -version-info $(LT_HL_VERS_INTERFACE):$(LT_HL_VERS_REVISION):$(LT_HL_VERS_AGE) $(AM_LDFLAGS)
# List sources to include in the HDF5 HL Library.
libhdf5_hl_la_SOURCES=H5DO.c H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c