summaryrefslogtreecommitdiffstats
path: root/hl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2016-04-13 18:48:16 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2016-04-13 18:48:16 (GMT)
commitd9c4a4c747908d3fdfd7e8bbef13635b2f4d5a60 (patch)
treecd558dbf5fe5d25d0965251d2ba14924c446d526 /hl/test/CMakeLists.txt
parent933adde73a7a2cf25bb0716a275ebff56807bf11 (diff)
downloadhdf5-d9c4a4c747908d3fdfd7e8bbef13635b2f4d5a60.zip
hdf5-d9c4a4c747908d3fdfd7e8bbef13635b2f4d5a60.tar.gz
hdf5-d9c4a4c747908d3fdfd7e8bbef13635b2f4d5a60.tar.bz2
[svn-r29690] Purpose: Merge PT improvements from trunk
Description: Merged from trunk: r29269: Improve Packet Table library r29295: Replaced H5Acreate with H5Acreate2 (by Larry) r29360: Adding missing tests r29364: Improve C++ Packet Table library r29554: Removed extra line in Copyright Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) Darwin (osx1010test)
Diffstat (limited to 'hl/test/CMakeLists.txt')
-rw-r--r--hl/test/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/hl/test/CMakeLists.txt b/hl/test/CMakeLists.txt
index 916dcf3..bf598c4 100644
--- a/hl/test/CMakeLists.txt
+++ b/hl/test/CMakeLists.txt
@@ -48,9 +48,19 @@ HL_ADD_EXE (test_ds)
HL_ADD_EXE (test_dset_opt)
HL_ADD_EXE (test_image)
HL_ADD_EXE (test_lite)
-HL_ADD_EXE (test_packet)
HL_ADD_EXE (test_table)
+# test_packet has two source files
+add_executable (hl_test_packet test_packet.c test_packet_vlen.c)
+TARGET_NAMING (hl_test_packet STATIC)
+TARGET_C_PROPERTIES (hl_test_packet STATIC " " " ")
+target_link_libraries (hl_test_packet
+ ${HDF5_HL_LIB_TARGET}
+ ${HDF5_LIB_TARGET}
+ ${HDF5_TEST_LIB_TARGET}
+)
+set_target_properties (hl_test_packet PROPERTIES FOLDER test/hl)
+
# --------------------------------------------------------------------
# This executable is used to generate test files for the test_ds test.
# It should only be run during development when new test files are needed