summaryrefslogtreecommitdiffstats
path: root/hl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-12-29 18:52:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-12-29 18:52:34 (GMT)
commit86313eb281deea495200c63f10d5efce38d3350c (patch)
tree828875fb28c5483668e28a970306f8a11e5da026 /hl/test/CMakeLists.txt
parent562ba69f3573acb5dd910dc227ca337320bbae8b (diff)
downloadhdf5-86313eb281deea495200c63f10d5efce38d3350c.zip
hdf5-86313eb281deea495200c63f10d5efce38d3350c.tar.gz
hdf5-86313eb281deea495200c63f10d5efce38d3350c.tar.bz2
[svn-r19895] Remove use of /MT compile flag for building static libs and programs. Added BUILT_AS_STATIC_LIBRARY define to set the windows import/export defines correctly for static libraries.
Diffstat (limited to 'hl/test/CMakeLists.txt')
-rw-r--r--hl/test/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/hl/test/CMakeLists.txt b/hl/test/CMakeLists.txt
index 22568ae..0f1cbf1 100644
--- a/hl/test/CMakeLists.txt
+++ b/hl/test/CMakeLists.txt
@@ -23,7 +23,6 @@ INCLUDE_DIRECTORIES (${HDF5_TEST_SRC_DIR})
MACRO (HL_ADD_TEST hl_name files)
ADD_EXECUTABLE (hl_${hl_name} ${hl_name}.c)
H5_NAMING (hl_${hl_name})
- TARGET_WIN_PROPERTIES (hl_${hl_name})
TARGET_LINK_LIBRARIES (hl_${hl_name}
${HDF5_HL_LIB_TARGET}
${HDF5_LIB_TARGET}
@@ -88,7 +87,6 @@ HL_ADD_TEST (test_table "test_table_be.hdf5;test_table_cray.hdf5;test_table_le.h
IF (HDF5_BUILD_GENERATORS AND NOT BUILD_SHARED_LIBS)
ADD_EXECUTABLE (hl_gen_test_ds gen_test_ds.c)
H5_NAMING (hl_gen_test_ds)
- TARGET_WIN_PROPERTIES (hl_gen_test_ds)
TARGET_LINK_LIBRARIES (hl_gen_test_ds
${HDF5_HL_LIB_TARGET}
${HDF5_LIB_TARGET}